Widespread WordPress Mobile Settings Bug

This morning I noticed a problem with the appearance of one of my WordPress blogs. Posts on the homepage were being displayed as excerpts. Yesterday, that was not the case.

20130227-183055.jpg

I soon noticed that it wasn’t just one of my blogs, but all of them.

20130227-183125.jpg

I checked my settings, not an easy task on mobile by the way. You can’t get to them in the WordPress iPhone app, you have to use mobile Safari. My settings were ok: excerpts are disabled.

20130227-183159.jpg

So why are excerpts still showing up on mobile?

I posted a question to the WordPress support forum. I have not gotten any answer.

I also noticed that my blogs are not the only ones affected. Every blog I checked seems to display the same way.

20130227-183229.jpg

No photos show up on the excerpts page, so a photo blog landing page looks like this:

20130227-183304.jpg

It’s not just mine; here are several other photo blogs:

20130227-183335.jpg

20130227-183357.jpg

20130227-183418.jpg

This is terrible. Who wants to scroll through that? What’s going to make anyone want to click on a post?

The best thing about reading blogs on the iPhone is the ease of scrolling through content. This just kills the experience.

So is this a bug? Or is it the new default WordPress behavior? I sure hope not.

If you have any information about this, let me know in the comments.


Update March 1, 2013:

Although there’s still no answer to my WordPress Forum post and I haven’t touched my settings, two days after I published this, with no fanfare and no explanation, everything seems to be working normally again.

Here are some snaps from the same blogs shown above:

IMG_4479

IMG_4478

IMG_4477

IMG_4476

IMG_4475

IMG_4474

Did WordPress see my posts and fix their bug, or did they find it on their own? I guess I’ll never know.

This entry was posted in Blog Notes, Blogging and tagged , , . Bookmark the permalink.

4 Responses to Widespread WordPress Mobile Settings Bug

  1. richfinck says:

    This happened to me after I run the latest WP update. I thought the theme wasn’t compatable with the update. I thanked WP for the screwup this morning on Twitter. I really don’t want to have to dig up a new theme. Thank you for posting and verifying it was WP screw up and I was not going nuts.

    • laura says:

      Hi Rich, Glad this helped you. If you have a few minutes, could you go over to the WordPress support forum to my question and reply to let them know you’re having the problem too? Maybe if more people reply it will get their notice.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s